3 Replies Latest reply: Apr 2, 2012 10:00 AM by Paul Lawbaugh RSS

Youtube PlugIn

Andrew Gray Newbie

We're using the tagbuilt 10.2 javascript and the youtube plug in as per PL's document (re-downloaded today) - it's dying with the following error. Looks like it's missing a definition of _wtyoutube....

 

Uncaught ReferenceError: _wtyoutube is not defined youtube_plugin.js:111

onYouTubePlayerAPIReadyyoutube_plugin.js:111

vbwww-widgetapi-vflibewTx.js:26

(anonymous function)www-widgetapi-vflibewTx.js:26

(anonymous function)

 

I'm guessing that the error is simple to fix but I'm not a js expert and I'd like to get this right not guess.

 

So what's wrong?

  • Youtube PlugIn
    Paul Lawbaugh Novice

    Hi Andrew,

    Did you add the plugin into the Webtrends html where you load the Webtrends base tag?

     

    The code for adding a plugin to a tag includes naming the function in the plugin that is launched and looks like:

     

    plugins:{

                webtrendsyoutube:{src:""webtrends.youtube.js""}

            }

     

    Obviously you need to make the src path correct though for your plugin location.

     

     

     

     

    Next you should see this function declared in your plugin so it shouldn't have an issue finding _wtyoutube.

     

    function () {

         _wtyoutube = new WebTrendsYouTube(tag, plugin);

     

     

     

     

     

    Note that these plugins are community supported (not tech support) so if you find something that works for you or your unique setup, please post it here on the dev network because we want to learn from you.

     

    Just for fun, here is a really simple test page with some of these plugins working on it:

    http://174.129.106.80/test.html

    This link is nothing official and may become broken at some point so don't count on it being around forever.